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Notice 

Notice 

Information contained in this document is believed to be accurate and reliable at the time of 
printing. However, due to ongoing product improvements and revisions, AudioCodes cannot 
guarantee accuracy of printed material after the Date Published nor can it accept responsibility for 
errors or omissions. Updates to this document can be downloaded from 
https://www.audiocodes.com/library/technical-documents. 

This document is subject to change without notice. 

Date Published: July-11-2023 

 

WEEE EU Directive 

Pursuant to the WEEE EU Directive, electronic and electrical waste must not be disposed of with 
unsorted waste. Please contact your local recycling authority for disposal of this product. 

Customer Support 

Customer technical support and services are provided by AudioCodes or by an authorized 
AudioCodes Service Partner. For more information on how to buy technical support for AudioCodes 
products and for contact information, please visit our Web site at 
https://www.audiocodes.com/services-support/maintenance-and-support. 

Abbreviations and Terminology 

Each abbreviation, unless widely used, is spelled out in full when first used. 

Documentation Feedback 

AudioCodes continually strives to produce high quality documentation. If you have any comments 
(suggestions or errors) regarding this document, please fill out the Documentation Feedback form 
on our Web site at https://online.audiocodes.com/documentation-feedback. 

https://www.audiocodes.com/library/technical-documents
https://www.audiocodes.com/services-support/maintenance-and-support
https://online.audiocodes.com/documentation-feedback
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1 Introduction 
This document describes AudioCodes' INI Viewer & Editor utility. 

INI Viewer & Editor simplifies viewing and editing of configuration (.ini) files used by AudioCodes 
Session Border Controllers (SBC), Media Gateways, and Multi-Service Business Routers (MSBR). 
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2 Installing INI Viewer & Editor 
The following procedure describes how to install INI Viewer & Editor on your PC. 

To install INI Viewer & Editor: 

1. Download the INI Viewer & Editor software file from AudioCodes website at 
https://www.audiocodes.com/library/firmware. 

2. Double-click the executable file (iniedit.exe); the installation wizard starts: 

Figure 1: Setup Wizard - Welcome 

 

3. Click Next; the following wizard page appears: 

Figure 2: Setup Wizard - Select Destination Location 

 

4. Click Next; the following wizard page appears: 

https://www.audiocodes.com/library/firmware
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Figure 3: Setup Wizard - Select Start Menu Folder 

 

5. Click Next; the following wizard page appears: 

Figure 4: Setup Wizard - Select Additional Tasks 

 

6. Click Next; installation of INI Viewer & Editor starts: 
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Figure 5: Setup Wizard - Installing 

 

When installation finishes, the following appears: 

Figure 6: Setup Wizard - Completing the INI Viewer & Editor Setup 

 

7. Click Finish. 
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3 Updating INI Viewer & Editor 
If a new version of INI Viewer & Editor is released, you are prompted to update it when you start the 
application: 

Figure 7: INI Viewer & Editor Update Message 

  

1. Click Get Update; the new version of INI Viewer & Editor is automatically downloaded and 
installed on your computer. 

Figure 8: Downloading New Version 

  

Once downloaded, installation begins automatically: 

Figure 9: Installing INI Viewer & Editor 

 

2. When installation finishes, quit INI Viewer & Editor and then restart it to activate the new 
version. 
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4 Getting Started 
This section provides a description of how to get started with INI Viewer & Editor. 

4.1 Starting INI Viewer & Editor 

The procedure below describes how to start INI Viewer & Editor. 

To start INI Viewer & Editor: 

◼ On your Windows taskbar, click Start  button, expand the AudioCodes folder, and then 

click  INI Viewer & Editor; INI Viewer & Editor starts, displaying the main window: 

Figure 10: Starting INI Viewer & Editor 

 

4.2 Areas of GUI 

The areas of the INI Viewer & Editor GUI are shown below and described in the subsequent table. 

Figure 11: Areas of GUI 
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Table 1: Description of GUI 

Item # Description 

1 Title bar, displaying the serial number of the device to which the configuration file belongs. 

2 Menu bar 

3 Toolbar with frequently needed command icons:  

 
New Creates a new file. 

Note: The icon is available only in Edit mode. 

 

Open Opens an ini file. 

 
Save Saves the file. 

 
Back / Forward Navigates you back and forward between tables when you 

click values in tables that are referenced to other tables. 

Note: These icons are available only in View mode. 

 
Undo / Redo Undoes the most recent action and redoes the most recent 

action. 

Note: These icons are available only in Edit mode. 

 

Cut Deletes selected text. 

Note: The icon is available only in Edit mode. 

 

Copy Copies selected text. 

Note: The icon is available only in Edit mode. 

 
Paste Pastes copied text. 

Note: The icon is available only in Edit mode. 

 
Find Searches a text string. 

 
Replace Replaces a string. 

Note: The icon is available only in Edit mode. 

 
Edit Table Opens the Edit Table dialog box, which allows you to edit the 

table in which your cursor is located. 

Note: The icon is available only in Edit mode. 

 
Preferences Opens the Settings dialog box, which allows you to customize 

INI Viewer & Editor. 

4 Tabs for choosing the display mode: 

◼ View tab 
◼ TXT tab 
◼ Edit tab 

For more information, see Changing Display Mode. 

5 Configuration file (.ini) contents  

6 "Table of contents" (TOC), allowing you to easily navigate to the location of a parameter in the 
ini file. For more information, see Locating Parameters Using "Table of Contents". 
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4.3 Defining Preferences 

You can customize INI Viewer & Editor to suite your preferences. 

To define preferences: 

1. From the Edit menu, choose Preferences (or on the toolbar, click  ); the Settings dialog 
appears: 

Figure 12: Settings Dialog Box 

  

2. Under the View Mode group, define your preferences for the View mode: 

• Comment font: Defines the font type and size for comments (see #3 in figure). 

• Section font: Defines the font type and size for sections (see #1 in figure). 

• Parameters font: Defines the font type and size for parameters (see #2 in figure). 

• Table font: Defines the font type and size for tables (see #4 in figure). 

• Beautify table column names: Enables easy-to-read table column titles (see #4 in 
figure). For example, instead of the ini file name 'PortDescription', the column title 'Port 
Description' is displayed. 

• Table columns: Defines the table column border width - Narrow, Normal and Wide (see 
#4 in figure). 
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Figure 13: Font Preferences for View Mode 

 

3. Under the TXT Mode group, define your preferences for the TXT mode: 

• Main font: Defines the font type and size for all text except sections. 

• Section font: Defines the font type and size for sections. 

4. Under the Edit Mode group, define your preferences for the Edit mode: 

• Edit font: Defines the font type and size for all text. 

5. Under the Dictionary group, define your preferences for INI Viewer & Editor's dictionary. The 
dictionary has a list of all parameters and possible values. It changes from version to version 
(with new parameters or values). The dictionary is used to expand enumerations of 
parameter values and to highlight invalid parameter names. For example, the 'Application 
Type' parameter in the Interfaces table displays “O+M+C” instead of “6”. 

• Use dictionary: Enables the use of the embedded dictionary. 

• Update dictionary file: Updates the dictionary with the latest version. 

• Match dictionary to INI version: Tries to "guess" the correct dictionary based on the INI 
header, which that contains the device's version. 
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6. Under the Miscellaneous group, define the following general preferences: 

• Save window position: Saves the current window size, and its position on your 
computer screen. If you quit INI Viewer & Editor, the next time you start it, it's displayed 
with the same size and in the same location on the screen as in your previous session. 

• Theme: Defines the display contrast theme: 

 Light: The GUI has a white background and tables displayed with blue and gray 
backgrounds. 

 Dark: The GUI has a black background. 

 Legacy: The GUI has a white background and tables displayed in white background. 

Figure 14: Contrast Theme Options (Light, Dark, Legacy) 

          

• Default tab on open: Defines the display mode (View, TXT and Edit) when you start INI 
Viewer & Editor. 

7. Click OK to save your preferences. 
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4.4 Viewing Version Information 

This section describes how to view INI Viewer & Editor version information. 

4.4.1 Viewing Version History 

You can view a brief description of the features and bug fixes per INI Viewer & Editor version. 

To view version history: 

1. From the Help menu, choose Version History; the following appears: 

Figure 15: Viewing Version History 

 

2. Click OK to close the dialog box. 

4.4.2 Viewing Version Number 

You can view the INI Viewer & Editor version number. 

To view version number: 

1. From the Help menu, choose About; the following appears: 

Figure 16: Viewing Version Number 

 

2. Click OK to close the dialog box. 
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4.5 Quitting INI Viewer & Editor 

The procedure below describes how to quit INI Viewer & Editor. 

To quit INI Viewer & Editor: 

◼ From the File menu, choose Quit. 
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5 Opening an ini File 
This section describes how to open an ini file with INI Viewer & Editor. 

To open an ini file: 

◼ Opening ini file when downloading from device's Web interface: 

a. Open the Configuration File page (Setup menu > Administration tab > Maintenance 
folder > Configuration File). 

b. Click Download INI File; the file automatically opens in INI Viewer & Editor. 

◼ Opening ini file previously saved on your computer: 

• From the File menu, choose Open. 

• Drag-and-drop the ini file into the INI Viewer & Editor's window. 

• Double-click the ini file. INI Viewer & Editor is typically installed as the default 
application for .ini file extensions, unless you explicitly disable this option during 
installation. 
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6 Changing Display Mode 
INI Viewer & Editor offers the following display modes for viewing the ini file: 

◼ View Mode: Read-only display mode, providing an easy-to-read format of the ini file. For 
lengthy ini files (e.g., IP Groups table with 50,000 rows), this view can't display all the content. 
In such cases, a message indicates the number of rows that aren't displayed. 

◼ TXT Mode: Read-only display mode, providing a text-based format of the ini file. This mode 
can also display lengthy ini files (e.g., IP Groups table with 50,000 rows). 

◼ Edit Mode: This is a read-write display mode, allowing you to view and modify the ini file. It 
displays the file like a text-based editor (e.g., Notepad). 

 

 
You can define the default display mode, as described in Defining Preferences. 

 

To view ini file in a specific display mode: 

◼ On the left side panel, click one of the following tabs: 

• View: Displays the ini file in View mode. 

• TXT: Displays the ini file in TXT mode. 

• Edit: Displays the ini file in Edit mode. 



7. Locating Parameters Using "Table of Contents" INI Viewer & Editor 

 

- 16 - 

7 Locating Parameters Using "Table of Contents" 
INI Viewer & Editor provides a "table of contents", which you can use to easily navigate to the 
parameter's location in the ini file. The "table of contents" lists all the ini file table parameters and 
the section names under which individual parameters are located. 

 

 
The "table of contents" is available only for View and TXT modes. 

 

To locate ini file parameter using "table of contents": 

1. Access the View or TXT display mode (see Changing Display Mode). 

2. On the toolbar, click the 'TOC' field (#1 in figure); a drop-down list appears, listing all the table 
parameters and parameter sections. 

3. Select the required parameter; INI Viewer & Editor navigates to the parameter and highlights 
it for easy identification (#2 in figure), as shown in the following example for parameters 
under the 'SYSTEM Params' section.  

Figure 17: Navigating to Parameter using TOC 
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8 Modifying an ini File 
This section describes how to modify the ini file. 

 

 
Modifying the ini file is available only in the Edit mode. 

 

8.1 Configuring Individual ini File Parameters 

You can configure individual ini file parameters (i.e., that are not tables). INI Viewer & Editor 
facilitates configuration by providing an auto-completion feature, which helps you enter parameter 
names and values, by offering suggestions based on your partial input. 

 

 

Parameters and values displayed by auto-completion and that don't appear in the device's 
User's Manual aren't officially supported and should not be used. 

 

To configure a parameter: 

1. Access the Edit mode, by clicking the Edit tab. 

2. On an empty line, press the Ctrl + Spacebar key combination; the auto-completion list 
appears. 

3. Start typing the first few letters of the parameter's name until the parameter appears in the 
list (e.g., "EnableAGC"), select it using the up or down arrow keys, and then press Enter: 

Figure 18: Adding Parameter with Auto-Completion 
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4. At the end of the parameter name, add a space, followed by an equal sign, followed by a 
space (e.g., "EnableAGC = "), and then configure the value of the parameter as follows: 

• Number values: Type the number. 

• String values (e.g., Enable or Disable): Press the Ctrl + Spacebar key combination, from 
the displayed auto-complete list, select the desired option using the up or down keys 
(e.g., "0 (Disable)"), and then press Enter. 

Figure 19: Configuring Parameter Value with Auto-Completion 
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8.2 Configuring Table ini File Parameters 

You can add rows to tables (or delete rows). 

To add a table row: 

1. Access the Edit mode, by clicking the Edit tab. 

2. Place your cursor anywhere in the table (e.g., Web Users table), and then from the Edit menu, 

choose Edit Table (or on the toolbar, click  ). 

Figure 20: Adding Table Row 

  

3. Click the Add button; a new row is added with default settings. 

4. Configure the row's fields (parameters), by clicking each field, and then typing the value or 
selecting a value from a drop-down list (if offered). 

5. Click OK. 

To delete a table row: 

1. Access the Edit mode, by clicking the Edit tab. 

2. Place your cursor anywhere in the table (e.g., Web Users table), and then from the Edit menu, 

choose Edit Table (or on the toolbar, click  ). 

3. Select a row, and then click Remove. 

4. Click OK. 
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8.3 Finding or Replacing ini File Strings 

You can search for strings and replace them if desired. 

8.3.1 Finding Strings 

The following describes how to search for strings. 

To find a string: 

1. Open the Find dialog box: 

• From the Edit menu, choose Find. 

• Press the Ctrl + F key combination. 

• On the toolbar, click  . 

Figure 21: Find Dialog Box 

  

2. In the 'Search string' field, type the string to be searched. 

Click Next; the first found string is highlighted in orange (#1 in figure) and the other occurrences in 
yellow (#2 in figure), as shown in the following example. You can move to the next found occurrence, 
by pressing F3 or by clicking a yellow line on the vertical scrollbar (#3 in figure). 

Figure 22: Found Strings Highlighted 
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8.3.2 Replacing Strings 

The following describes how to find and replace strings. You can only do this in Edit mode. 

 

 
The find-and-replace feature is available only in the Edit mode.  

 

To find and replace a string: 

1. Access the Edit mode, by clicking the Edit tab. 

2. Open the Replace dialog box: 

• From the Edit menu, choose Replace. 

• Press the Ctrl +H key combination. 

• On the toolbar, click  . 

Figure 23: Replace Dialog Box 

  

3. In the 'Search string' field, type the string that you want replaced. 

4. In the 'Replace with' field, type the replacement string. 

5. Click Find. 

6. Click Replace or Replace All to replace the text. 
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